service_setup.cmd error : no admin login exiting

kressefresser
Beiträge: 18
Registriert: 11 Nov 2008, 17:39

service_setup.cmd error : no admin login exiting

Beitragvon kressefresser » 12 Nov 2008, 16:50

Hallo,

ich habe das gleiche Problem wie https://forum.opsi.org/viewtopic.php?f=7&t=54&sid=0b6d401f6195b9db454debef76bdb5c3.

Ich gebe den Benutzer/Passwort von einem User ein der in der OPSIAdmin Gruppe ist, der User kommt auch in /configed rein und dennoch sagt es immer "Error: no admin login - exiting".

Kann ich das irgendwo debuggen oder mehr Output erhalten um den Fehler einzugrenzen?

Kann es sein, dass das Problem mit dem LDAP Backend zusammenhängt?

Welche Rechte benötigt der User?

Bis dahin

Oliver

Benutzeravatar
d.oertel
uib-Team
Beiträge: 3269
Registriert: 04 Jun 2008, 14:27

Re: service_setup.cmd error : no admin login exiting

Beitragvon d.oertel » 14 Nov 2008, 12:26

Hallo,

service_setup.cmd
schickt die Log-Datei nach
%TEMP%\preloginloader.log
diese mal posten....
Wichtig ist aber auch die Serverseitige Log-Datei:
/var/log/opsi/opsiconfd/<ip-nummer>.log
hier müsste stehen das der user/passwd geprüft und abgelehnt wird.

gruss
detlef oertel
opsi support - uib gmbh

For productive opsi installations we recommend support contracts.
http://www.uib.de
http://www.opsi.org

kressefresser
Beiträge: 18
Registriert: 11 Nov 2008, 17:39

Re: service_setup.cmd error : no admin login exiting

Beitragvon kressefresser » 14 Nov 2008, 13:01

Hallo:

Logfile für Client:

Code: Alles auswählen

(1) Nov 14 11:44:25 Traceback: (Logger.py|480)
(1) Nov 14 11:44:25      line 762 in 'process' in file '/usr/sbin/opsiconfd' (Logger.py|480)
(1) Nov 14 11:44:25      line 670 in 'authenticate' in file '/usr/sbin/opsiconfd' (Logger.py|480)
(1) Nov 14 11:44:25      line 132 in '__init__' in file '/var/lib/python-support/python2.4/OPSI/Backend/BackendManager.py' (Logger.py|480)
(1) Nov 14 11:44:25      line 218 in '_authenticate' in file '/var/lib/python-support/python2.4/OPSI/Backend/BackendManager.py' (Logger.py|480)
(1) Nov 14 11:44:25      line 305 in '_pamAuthenticate' in file '/var/lib/python-support/python2.4/OPSI/Backend/BackendManager.py' (Logger.py|480)
(1) Nov 14 11:44:25      ==>>> PAM authentication failed for user 'none': ('Authentication failure', 7) (opsiconfd|765)
(2) Nov 14 11:44:25 Forbidden: PAM authentication failed for user 'none': ('Authentication failure', 7) (opsiconfd|766)
(2) Nov 14 11:45:28      line 776 in 'process' in file '/usr/sbin/opsiconfd' (opsiconfd|786)
(2) Nov 14 11:45:28      line 831 in 'execute' in file '/usr/sbin/opsiconfd' (opsiconfd|786)
(2) Nov 14 11:45:28 Method 'userIsAdmin' is not valid (opsiconfd|790)
(1) Nov 14 12:02:46 Traceback: (Logger.py|480)
(1) Nov 14 12:02:46      line 762 in 'process' in file '/usr/sbin/opsiconfd' (Logger.py|480)
(1) Nov 14 12:02:46      line 670 in 'authenticate' in file '/usr/sbin/opsiconfd' (Logger.py|480)
(1) Nov 14 12:02:46      line 132 in '__init__' in file '/var/lib/python-support/python2.4/OPSI/Backend/BackendManager.py' (Logger.py|480)
(1) Nov 14 12:02:46      line 218 in '_authenticate' in file '/var/lib/python-support/python2.4/OPSI/Backend/BackendManager.py' (Logger.py|480)
(1) Nov 14 12:02:46      line 305 in '_pamAuthenticate' in file '/var/lib/python-support/python2.4/OPSI/Backend/BackendManager.py' (Logger.py|480)
(1) Nov 14 12:02:46      ==>>> PAM authentication failed for user 'none': ('Authentication failure', 7) (opsiconfd|765)
(2) Nov 14 12:02:46 Forbidden: PAM authentication failed for user 'none': ('Authentication failure', 7) (opsiconfd|766)
(2) Nov 14 12:03:04      line 776 in 'process' in file '/usr/sbin/opsiconfd' (opsiconfd|786)
(2) Nov 14 12:03:04      line 831 in 'execute' in file '/usr/sbin/opsiconfd' (opsiconfd|786)
(2) Nov 14 12:03:04 Method 'userIsAdmin' is not valid (opsiconfd|790)


Die Datei preloginloader.log finde ich auf dem Rechner nicht :?

Wenn ich den Log richtig verstehe übergibt er keinen User oder?

Was kann ich tun?

Bis dahin

Oliver

Benutzeravatar
j.schneider
Ex-uib-Team
Beiträge: 1414
Registriert: 29 Mai 2008, 15:14

Re: service_setup.cmd error : no admin login exiting

Beitragvon j.schneider » 14 Nov 2008, 13:15

Hallo,

da scheint auf dem Server eine alte Version von python-opsi installiert zu sein.
Was sagt:

Code: Alles auswählen

dpkg -l | grep opsi

kressefresser
Beiträge: 18
Registriert: 11 Nov 2008, 17:39

Re: service_setup.cmd error : no admin login exiting

Beitragvon kressefresser » 14 Nov 2008, 13:18

Der sagt:

Code: Alles auswählen

ii  opsi-atftpd                   0.7-7                                advanced TFTP server - Opsi FiFo version
ii  opsi-configed                 1.2.0-4                              OPSI config editor
ii  opsi-depotserver              3.2-3                                server fuer das Softwareverteilungssystem OPSI
ii  opsi-linux-bootimage          20080207-1                           Linux-Bootimage fuer das Softwareverteilungssystem OPSI
ii  opsi-utils                    3.2.0.2-1                            OPSI utils
ii  opsiconfd                     1.0.5-4                              OPSI configuration service
ii  opsipxeconfd                  0.2-3                                OPSI PXE configuration daemon
ii  python-opsi                   3.2.0.12-1                           OPSI python library

Benutzeravatar
j.schneider
Ex-uib-Team
Beiträge: 1414
Registriert: 29 Mai 2008, 15:14

Re: service_setup.cmd error : no admin login exiting

Beitragvon j.schneider » 14 Nov 2008, 17:15

Das ganze System läuft noch auf opsi 3.2.
Nach einem Update auf opsi 3.3 sollte es klappen.
Wenn dies nicht gewünscht ist bitte den Preloginloader für opsi 3.2 verwenden.